Kawasaki VN750 Forum banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
40 Posts
Discussion Starter #1
At something north of 25000 miles on a hot day (before I knew of this forum) I lost my stator, probably in traffic at a stop light. I didn't have any mods (r/r reloc, m/f batt, etc.) done and it cost me mucho time to partial/pull the engine to replace the stator. I could not have done it without the information on this site and I STILL didn't do it right. My new stator had the wiring harness clamp situated in such a way as to allow the stator wires to get into the rotor and chaffed the wires. Right now they are repaired and I am hoping that the repair will last until the first snow and I will change the stator AGAIN and be MUCH more careful. So I have another Electrosport stator awaiting a cold weekend. I mainly wanted to say to say thanks for all of the people on this site that provided me with much needed information.
 

·
Registered
Joined
·
115 Posts
cool a fellow kc'er!! Down in Olathe here.. Gotta do my stator also.
 

·
and the Adventure Cycle
Joined
·
6,141 Posts
So I have another Electrosport stator awaiting a cold weekend. I mainly wanted to say to say thanks for all of the people on this site that provided me with much needed information.
There have been a few people here who've mentioned the Electrosport quality seeming to be on the decline. Have you contacted Electrosport about the issue?
 

·
Registered
Joined
·
10 Posts
Sorry to hear that bro! Had to do the stator in mine also, got it on Ebay (RM Stator Inc). Did that and a MF Big Crank battery and so far, so good!
 
1 - 4 of 4 Posts
Top