Kawasaki VN750 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Installed new turn signals on my 93 Vulcan 750. Bulbs are good. Right turn signal operates normally, the left blinks fast. swapped wires on front signals, got fast flashing on right, so i know it's not the lights. The hazard lights blink fine in rear, alternate flashing on front signals, thats weird! Tried a different turn signal relay, NO CHANGE!! Now I'm stumped!! What else could it be??
 

·
Registered
Joined
·
1,377 Posts
fast flashing usually means the mate in the front/back pair is burnt out. when you have fast flashing on the front signal, what is the rear doing? Sounds like both are lighting up when the hazards are engaged, but can you verify that? Might be a weak short to ground in the harness between flasher module and signals.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
Rear left flashes fast like the front one on left side. Thought for sure it would be the relay, but after trying a different one, no luck. I've swapped bulbs in front and still the same thing on left side. I even tried hooking up my older turn switch to see if the switch was the issue, but nope, same problem. What else regulates the flashing??
 

·
Registered
Joined
·
1,377 Posts
It's a higher-than-expected resistance situation, so you could check to see if your blinker circuit grounds are clean and secure. Are your new lights LEDs?
 

·
Premium Member
Joined
·
3,027 Posts
"The hazard lights blink fine in rear, alternate flashing on front signals" Are you absolutely sure about that? Can you put the old signals back and see what happens?
 
1 - 5 of 5 Posts
Top