Kawasaki VN750 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
227 Posts
Discussion Starter · #1 ·
I know someone had this problem before but I can't find a fix in the archives. I have a 1986 that I bought used, it hadn't been running for over a year. I've finally got it running, new maintenance free battery does wonders for hard to start bikes. Now my tach jumps all over the place. At idle it seems to be reading about right but when you open the throttle it actually goes to zero and then bounces all over the place. The bike doesn't feel like it's misfiring on either cylinder and the throttle response is good.
 

·
Premium Member
Joined
·
650 Posts

·
Registered
Joined
·
227 Posts
Discussion Starter · #3 ·
Too bad nitrofish420 didn't post what was actually causing his problem. It sounds alot like what mine is doing. To test the kickstand switch all I should have to do is try taking off with the kickstand down?
 

·
Uber Member
Joined
·
1,280 Posts
i seem to only have the prob when the clutch is in and the kickstand is down.... shortly after engine is killed (they safety thinggy). doesnt seem to cause any other problems
 

·
Registered
Joined
·
32 Posts
quitting

my 87 sometimes will quit on me when the kickstand is up and the KICKSTAND SAFETY SWITCH looks all the way out. i put it in gear and go to give it a little gas and it just quits. it will do it multiple times then i have to turn off the ignition and then turn it back on and then it works fine. is this ignition or safety switch? also can you disconnect the safety switch all together? any help is appreciated.:D :smiley_th :carryflag
 

·
Registered
Joined
·
227 Posts
Discussion Starter · #6 ·
The more I dig the more I find. My safety switch is bad, stuck in open, so that shouldn't be it. I have one spark plug that is only firing part of the time (checked all four wires with an inductive type timing light, three are constant strobe one visibly flickers). I'm going to change that coil and see if things get better. My ignition switch is acting up also, jiggle it and all lights go out or bike dies and lights stay on. Like I said originaly, bike was a fixer upper, and I'm having fun working on her.
 

·
Registered
Joined
·
32 Posts
wwmkwood said:
The more I dig the more I find. My safety switch is bad, stuck in open, so that shouldn't be it. I have one spark plug that is only firing part of the time (checked all four wires with an inductive type timing light, three are constant strobe one visibly flickers). I'm going to change that coil and see if things get better. My ignition switch is acting up also, jiggle it and all lights go out or bike dies and lights stay on. Like I said originaly, bike was a fixer upper, and I'm having fun working on her.
try replacing the wire first before replacing the coil. i had the same problem and replaced the wires and it went away. real easy to do.:D
 

·
Premium Member
Joined
·
650 Posts
wwmkwood said:
My ignition switch is acting up also, jiggle it and all lights go out or bike dies and lights stay on. Like I said originaly, bike was a fixer upper, and I'm having fun working on her.
Same thing happened with mine. There's some write-ups on how to rebuild/clean up your ignition switch in the Verses I believe. Doesn't take long and worked great for me.
 

·
Registered
Joined
·
227 Posts
Discussion Starter · #9 ·
All new plug wires already (took it back apart to make sure it was seating). Thick blue spark when it is firing. As far as the ignition switch, need to change it any ways, key comes out on it's own in the run position. I'd hate to loose a key at 70 mph.
 
1 - 9 of 9 Posts
Top