Kawasaki VN750 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Ok, i've got the engine out and the casing off, took the old stator out and went to fit the new one but there is one very small difference. The old stator has a recess on the inner hole which sits over a lip on the casing, the new one does not have the recess, anyone come across this and is there anything i can do or do i have to get a new stator???
 

·
and the Adventure Cycle
Joined
·
6,141 Posts
What kind of stator is the new one? Electrix, Rick's, something else?
 

·
Concert connoisseur
Joined
·
2,231 Posts
wish i could help. mine was ricks and fit fine. sorry
 

·
Simple Solutions
Joined
·
965 Posts
do the holes line up? im on my third one from dennis kirc one from electo sport and im gonna send this one in to get wound all in all i'm not gonna go the cheap route n e more and if yours doesnt fit i recomend getting it wound with quality wire nothin worse then doin it again and again oh wait and again.... mine have all fit snugly in place and bolted up nicely///
 

·
Premium Member
Joined
·
100 Posts
I've changed 2 stators on my bike now.
First one, I had one sent to me by Electrosport (forgot the name! Is that the company?). Turned out, it was for a Honda. Looked almost identical, but had a slight variation in spacing or center hole size. I can't recall now. Sent it back and got another one sent to me and it fit perfectly.
It burned out before too long, though.
So I ordered another Kaw original equipment stator. I opened up the bandages around the joints to see if they had done the joints right (staggered the joints and soldered them along with clamping). This one was done right. I've had it on for a couple of years now, some 20,000 miles (the others burned out at about 10,000).
Difference else that I did:
I put the RR unit (a new one just to be sure) up in front where it belongs, and I wired it with one gauge up size wiring (from stator to RR, and RR to box) so that the wires wouldn't get hot and increase the resistance (load) on the stator.
Seems to be working.
But you probably won't get that stator on your engine if it is not PRECISELY fitting. And if you do manage to get it on, you'll probably find something grinding pieces off since the clearances are really close.
 
1 - 6 of 6 Posts
Top