Kawasaki VN750 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
I have a 97 vn750 with 45,000 miles on it. I pulled off the carbs today and gave them a good cleaning ,inspection and replaced the float needles. after putting everything back together I have found two problems. first one I posed in the engine cooling section cause I created a cooling leak that I can't seem to fix. the other is that when I ride the engine wants to cut out. it seems like it isn't getting any fuel. If I hold the throttle wide open long enough it will pick back up... It idles fine though. Any ideas
 

·
HAWK
Joined
·
2,576 Posts
Have you checked the fuel lines running to the Carbs. If you switch the vacume lines and fuel lines will cause problems.
Has the bike had a Ear shave?
If not there is a vacume line running to the Right ear, check that and make sure it is not off or bottomed out.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #3
I have checked to be sure all the lines are going to the right places and they are. Any other ideas. ..... When I changed the float needles is there a possibility that I could have messed something else up in the carb?
 

·
Super Moderator
Joined
·
11,970 Posts
If the bike ran fine before you touched the carbs, then it would seem you did something that has caused a problem. You say you replaced thefloat needles?
Did you check the float height?
It's also possible that something is blocking a jet, or the diapham(s) are sticking. If it seems to stumble with the throttle cranked wide open, but then "catches up" and runs fine, it would seem to suggest it is not starving for fuel but getting to much in the mid range.

First try shooting some carb cleaner through all the orifices and running some SeaFoam through the carbs. pull the intake boots off the carbs to make sure the throttle valves are going up and down smoothing and at the same time (with the engine off of course)
One little spec of goo can screw up a carb, so if none of the above work, you might have to take them off again and re-clean them.
Check the diaphrams for tears or holes, shoot Gumout spray through every hole and before you bolt the carbs back on, make sure the float valve is working, by using a small funnel attached to the fuel line and pouring some gas, (or seafoam) into it and seeing if the valve closes and does not leak.
You should check the vacuum line to the right air box to make sure it is not bottomed out, many cut the end at 45 degrees so it can't.

Good luck,
KM
 

·
Registered
Joined
·
158 Posts
When you check the vacuum hoses did you make sure they were no cracks in them. I have had a large hole in the one for the rear carb and it caused the bike to bog down around 3K. replaced the hoses when I rejetted the carbs and that fixed the problem.
 

·
Waffle House regular…
Joined
·
60 Posts
See if this helps...

The problem went like this. Twist the throttle and you begin to move out, then as you continue to twist the throttle it has less and less effect. As if it is starving for fuel or the throttle is not working.

Well I had a hunch I knew what it was. When rebuilding the carbs I had a problem with the Vacuum piston / diaphragm assembly. The diaphragm did not want to seal properly but I thought I had them in right. Nothing to do but pull the carbs yet again! Well that was part of the problem. Another thing was the spring seat for the needle jet. You need to pay attention to the hole in the bottom of the Vacuum piston / diaphragm assembly, there are two. One is for the needle and the other hole is to allow for air pressure differential, which is what moves the diaphragm up and down. I am not sure I checked this before reinstalling them the first time.

Once I fixed these, the bike runs like it should!

If you rebuild or clean your carbs pay particular attention to these areas. I used a very small amount of gasket sealer to help hold my diaphragm in place during instillation.
 
1 - 6 of 6 Posts
Top