Kawasaki VN750 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
450 Posts
Discussion Starter #1
Darnitt had bike runin good...now it wont "take the gas",try to open it up in each gear it "Boggs"...creeps a lil faster,dont think I've seen sixty in four trips!!Added fresh gas and 1/4 can Seafoam...so far no change.Thing is my Vulcan don't sit...I drive it 4-5 times a week.
 

·
Registered
Joined
·
1,347 Posts
I wondered the same thing!

In my inexperience I'd check for a blockage in the main jets. Seafoam might not do anything to a complete blockage, or a major blockage caused by solid particles. How does the inside of the tank look? any rust etc?
 

·
Registered
Joined
·
450 Posts
Discussion Starter #4
My Vulcan was "Chugging" along acting sluggish...like its been.One point I was like "OK gonna throttle this bit** "...sucker jumped from 55+ to 70 wabam!!So hoping something blew out a jet..or somthin.Rode normal last 2-3 miles to the 'ol J.O.B.
 

·
Registered
Joined
·
774 Posts
same kinda thing happened to me a few weeks ago.

I can see why they got rid of carburetors in the grand scheme of things
 

·
Registered
Joined
·
774 Posts
yeah I think the injectors on my '92 Pathfinder are starting to go, too

then again, that's at 245k miles...

and I have to take the intake plenum off to replace them...

what is it with my vehicles and having air intakes block access to fuel delivery systems? intake plenum, surge tank, same foe
 

·
Registered
Joined
·
450 Posts
Discussion Starter #10
So cant find my "Had to walk home thread" so...took bike to shop for charge system check...for 35 bucks told me AGM sealed battery no good.So picked one up from Advance for $75...hope that does it.
 
1 - 11 of 11 Posts
Top