Kawasaki VN750 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
had a mechanic do some engine work, but now i find myself fixing the mistakes, so i don't know why i paid him in the first place. he got a license plate mount that is a brake light as well, running works and when u press the brake it doesn't do ****. where would i start?
 

·
Registered
Joined
·
1,253 Posts
There should be two wires running to the tail light assembly. One powers the running light, the other powers the brakes.
First, check to see if either brake triggers the light. Could be one bad switch. If neither switch illuminates the bulb, use a voltmeter to see if you're getting power to the brake light wire. If yes, replace the bulb. If the bulb is good ... well ... uh ... hopefully you just need a new bulb and you won't have to worry about that part!
 

·
Super Moderator
Joined
·
2,569 Posts
if the brake light is on all the time, you need to adjust the brake switch mounted down by the foot (rear) brake pedal. you will need to 'screw' it inwards in order to have the switch in the off position when pedal is released. when you push down on the pedal, it pulls on the switch actuator (it has a spring on it if I recall thats used to prevent over extending the switch and breaking it)

front brake lever has a switch as well, but not adjustable
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
cool, its just a screw? man maybe i should be looking closer at things. sounds really simple. this is my first project and im running into alot of minor problems. nothing major knock on wood
 

·
Registered
Joined
·
7,662 Posts
Odd setup from others I've seen. The threaded fitting has tabs that lock in the hole and a hex on top. (this one is a little butchered)

Best bet is use a wrench on the hex, otherwise you'll be twisting the wires (as in the pic).

 
1 - 7 of 7 Posts
Top