Kawasaki VN750 Forum banner

1 - 11 of 11 Posts

·
Youngster
Joined
·
154 Posts
Discussion Starter #1
Even after the rebuild mine continues to give me trouble, still gonna try to fix it, but was wondering if anyone has an extra lying around they'd be nice enough to sell to me?
 

·
romeobravo172
Joined
·
842 Posts
What is happening after rebuild?
 

·
Registered
Joined
·
323 Posts
Even after the rebuild mine continues to give me trouble, still gonna try to fix it, but was wondering if anyone has an extra lying around they'd be nice enough to sell to me?
I rebuilt mine and it worked perfectly. But then I discovered a small hole in the filter and decided to buy new. It's yours for shipping. I'll take pix if you want.
 

·
Youngster
Joined
·
154 Posts
Discussion Starter #4
Alright, so it was slowly leaking before. I buy the rebuild kit, put it in and now if i put it on anything but off its gushing out fuel. off a 1990... Gonna take it off and rule out if I put it on wrong tomorrow. Like it's a steady stream of gas pouring out. Can't even start because of it.

@DaCataldo I'll let u know after tomorrow. If I don't go surfing that is :p
 

·
Linkmeister Supreme
Joined
·
7,960 Posts
I rebuilt mine and it worked perfectly. But then I discovered a small hole in the filter and decided to buy new. It's yours for shipping. I'll take pix if you want.
Alright, so it was slowly leaking before. I buy the rebuild kit, put it in and now if i put it on anything but off its gushing out fuel. off a 1990... Gonna take it off and rule out if I put it on wrong tomorrow. Like it's a steady stream of gas pouring out. Can't even start because of it.

@DaCataldo I'll let u know after tomorrow. If I don't go surfing that is :p
If it is ok with you Dave, I call dibs on the petcock if 1stVulcan doesn`t take it. :)
 

·
Youngster
Joined
·
154 Posts
Discussion Starter #6
Go for it Hoss, turns out I was a tard and didn't tighten the screws enough :p.
 

·
Linkmeister Supreme
Joined
·
7,960 Posts
Thanks for the heads up 1st Vulcan.
PM sent Dave.
 

·
Youngster
Joined
·
154 Posts
Discussion Starter #8
I drove the bike today for the first time since adjusting the float bowl, and rebuilding the petcock. Bike idles great, but when I give it throttle it just can't seem to get enough gas and sometimes kills itself. Taking out the vacuum part of the petcock and just putting on a gasket on and sealing it up, should allow plenty of flow of gas. Tomorrow I register the bike :beerchug:
 

·
romeobravo172
Joined
·
842 Posts
It sounds like when that petcock got rebuilt that the diaphram was not alligned properly(very easy to miss that). There is a small nipple sticking out that has to fit in the housing, and it looks fine but will leak if it's not in correctly. Been there did that!!! DA!! Those things are so simple to rebuild, but simple things like that line up nipple can be over looked.
 
1 - 11 of 11 Posts
Top