Kawasaki VN750 Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
hi, im new to the vn 750, got the bike about a month ago, bike worked good i decide to go with straight pipes, and do the ear shave and went with pod filters, now the bike idles fine, went down the road and back and bike wont rev past 3,000 rpms only gegting about 1/3 trottle and starts popping and back firing.. im think i need to get jets??
 

·
Registered
Joined
·
9,265 Posts
emgo pod filters with straight pipes and stock jets, 38 pilot 138 main
Ok, asking because certain filters will block ports at the carb throat. Emgo is somewhat unknown for the earshave, but I think someone else here recently used them successfully. K&N and UNI are known to work.
 

·
FREEBIRDS MC CENTRAL NY
Joined
·
16,419 Posts
Emco pod filters block the passages. Get K&N if you stick with pods. Or uni foam ones. I went K&N, degoated, with Harley screaming eagle muffs. 140/40 with two shims under the needle

Sent from my A501DL using Tapatalk
 
  • Like
Reactions: Spockster

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
i got stage 3 carb jets (40 pilot, 140 main, 2 shims for each needle) in the mail today, and emgo pod filters, i cut out the piece of the rubber that blocks the air passage that raises the needle ( shown in picture),, i will give update soon as i get it all put on bike in next couple days
53698
53699
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #8 ·
i got the jets put in ( 40 pilot, 140 main, 2 shims under each needle),pod filters put on, bike idles good, goes right to WOT, feels like more power then ever,, she dont have no popping on decel like she did before, but when just cruising along she not right like she flooding or buckin???.. it was dark when i got back from test ride im wondering do i need to adjust pilot screws?
 

·
Registered
Joined
·
9,265 Posts
i got the jets put in ( 40 pilot, 140 main, 2 shims under each needle),pod filters put on, bike idles good, goes right to WOT, feels like more power then ever,, she dont have no popping on decel like she did before, but when just cruising along she not right like she flooding or buckin???.. it was dark when i got back from test ride im wondering do i need to adjust pilot screws?
No, the mixture adjustment has little to no effect above idle.

At what rpm do you see the problem? Is it truly bucking, or more of a surge?

Might try removing one shim on each carb. Make sure there's no air leaks before any tuning.

How do the plugs look?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #10 ·
it was happening at around 4000 rpms maybe little less. when i go to pick up speed shes fine, but when im just staying at one speed cruiseing along its like she was cutting in and out,,, also i forgot to metion i did put 4 new plugs in when i put in the new jets they didnt have any ngk iridium so they match it up with champion plugs and now my bike is hard to start especially when hot
 

·
Registered
Joined
·
9,265 Posts
Sounds like it has a 'burble' at cruise, from being too rich.

At 4000 it's running on the mains, so I'd try removing one shim each. The slide needles are on the main jets.

Since it may be running on the rich side, try opening the throttle for hot starts.

You could try the old plugs if you think the new ones are causing the start problem.
 

·
Registered
Joined
·
1,844 Posts
No. My son and I just got back from a camping trip (he's on the VN, I'm on my GL500 ADV build). With the pods and Sporty mufflers, I'm going up to 145 mains. 42 low speed seems fine.
53747
 

·
Registered
Joined
·
1,844 Posts
i got the jets put in ( 40 pilot, 140 main, 2 shims under each needle),pod filters put on, bike idles good, goes right to WOT, feels like more power then ever,, she dont have no popping on decel like she did before, but when just cruising along she not right like she flooding or buckin???.. it was dark when i got back from test ride im wondering do i need to adjust pilot screws?
Sync your carbs.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #17 ·
i got the bike running good, i synced the carbs and after that she ran fine she was running too rich woth the new jets,, I didnt like the sound of the bike with no mufflers, now i got 2 harley mufflers that i chopped and shortened i left the baffles in the mufflers, she sounds really good now and ahe got good low end power but she dont have the high end power like she had before..i was thinking maybe shes running to rich with tthe 2 shims under each needle at WOT... do you think i should remove the two shims from under the needle???
 

·
Registered
Joined
·
9,265 Posts
.i was thinking maybe shes running to rich with tthe 2 shims under each needle at WOT... do you think i should remove the two shims from under the needle???
That would be the best place to start, and smaller adjustment than jumping jet sizes. The shims affect high rpm range the most because of the taper on the slide needle.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #19 ·
That would be the best place to start, and smaller adjustment than jumping jet sizes. The shims affect high rpm range the most because of the taper on the slide needle.
thanks for the reply, when i get a chance i will take the carbs off and remove the shims
 
1 - 19 of 19 Posts
Top