Kawasaki VN750 Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1
Went on a poker run and noticed my petcock was leaking just a little. I found tons of new ones cheap for the VN750, but none said they would work on the VN700. Are they the same ? Thanks
 

·
FREEBIRDS MC CENTRAL NY
Joined
·
16,076 Posts
same on all.can also use one from a Yammie tw200. they eliminate the vacuum activation. if you go that route get the more expensive one

Sent from my LGL34C using Tapatalk
 

·
Registered
Joined
·
86 Posts
Discussion Starter #3
Thanks

Thanks Doc :smile2:

Can't believe how cheap they are, 10 bucks on Ebay with 250 sold and 100% positive feedback on them. I rode my bike today and decided I will do everything it takes to get it into 100% shape. I can't believe how much I like this bike, even more than my V65 Magna I bought new in 1984 ! I loved that bike but sadly I was a heavy whiskey drinker back then, and one too many times going 160 after the bar, and I sold it while I was ahead. It was way faster of course, but nothing beats this 32 year old Vulcan IMHO.
 

·
FREEBIRDS MC CENTRAL NY
Joined
·
16,076 Posts
go with the oem Yamaha ones.might cost $25 bucks but are of better quality than the cheap ones

Sent from my LGL34C using Tapatalk
 

·
FREEBIRDS MC CENTRAL NY
Joined
·
16,076 Posts
you also need to cap off the vacuum line off the carb

Sent from my LGL34C using Tapatalk
 

·
Registered
Joined
·
86 Posts
Discussion Starter #6

·
FREEBIRDS MC CENTRAL NY
Joined
·
16,076 Posts
it says it's oem,so it should be fine. you will also need a t fitting, as the tw petcock only has one fitting, where the vn has two

Sent from my LGL34C using Tapatalk
 

·
Registered
Joined
·
86 Posts
Discussion Starter #9
Around Valve lever

It is leaking around in a cirlcle around the valve on-off-reserve lever. Never had one leak there, I have changed alot of petcocks and usually it is like you say, either the hoses or the gasket at the tank. Thanks for the help.
 

·
FREEBIRDS MC CENTRAL NY
Joined
·
16,076 Posts
It is leaking around in a cirlcle around the valve on-off-reserve lever. Never had one leak there, I have changed alot of petcocks and usually it is like you say, either the hoses or the gasket at the tank. Thanks for the help.
probably either the o-ring around the lever,or the o-ring inside with the four holes

Sent from my LGL34C using Tapatalk
 

·
Registered
Joined
·
7,650 Posts
That does not look like OEM! Some of these Ebay vendors are known to outright lie...

Has anyone tried using of those rebuild kits for EOM petcock valves?
Rebuild for OEM? Yes, got a kit off ebay, easy to do.

That last link was for a TW200, it does away with the vacuum setup.
 

·
FREEBIRDS MC CENTRAL NY
Joined
·
16,076 Posts
That does not look like OEM! Some of these Ebay vendors are known to outright lie...

Has anyone tried using of those rebuild kits for EOM petcock valves?
oem Yamaha tw200.it is commonly used on vn750's as a cheaper replacement for the vn's petcock, which also does away with the vacuum activation. seeing as this is your first post, would you mind doing an introduction in the newbie section so we can get to know you a little? thank you
That does not look like OEM! Some of these Ebay vendors are known to outright lie...

Has anyone tried using of those rebuild kits for EOM petcock valves?
oem Yamaha tw200.it is commonly used on vn750's as a cheaper replacement for the vn's petcock, which also does away with the vacuum

Sent from my LGL34C using Tapatalk
 

·
FREEBIRDS MC CENTRAL NY
Joined
·
16,076 Posts
Rebuild for OEM? Yes, got a kit off ebay, easy to do.

That last link was for a TW200, it does away with the vacuum setup.
sorry Spockster didn't see your post

Sent from my LGL34C using Tapatalk
 

·
Registered
Joined
·
86 Posts
Discussion Starter #15
Seafoam

In the original post I stated my petcock just started leaking. Now I know why. I poured a whole can of seafoam in my tank and that is what made it start leaking. I know a whole can is overkill. Just didn't get the connection until I rode today, 2 tanks of gas later, and it is not leaking anymore. Must of just cleaned it out so much it leaked a little around the valve, but it is not leaking a drop now. Thanks for the help guys, I all ready ordered the TW petcock and will put it on when I do the stator job this fall.
 

·
Registered
Joined
·
3 Posts
Does it matter what year TW200 petcock, or will any year fit? I.E. I have a 93 Vulcan 750, do I get a 93 TW200 petcock?

Sent from my SAMSUNG-SM-G890A using Tapatalk
 
1 - 17 of 17 Posts
Top