Kawasaki VN750 Forum banner

1 - 5 of 5 Posts

·
oldman1113
Joined
·
1 Posts
Discussion Starter #1
I have a '95 Vulcan and my high beam and headlamp light stay on all the time. The high and low beam seem to be working but the bulbs stay on. Does anyone have any idea what's going on.
 

·
Premium Member
Joined
·
3,026 Posts
Not sure what you are asking. The high beam and low beam are the same bulb. One or the other will always be on when the engine is running. They will also stay on if the engine dies and the switch is still on. There is no off switch. If the headlight stays on all the time even with the switch off, then you have an electrical problem somewhere.
 

·
2000 VN 750 Senior Member
Joined
·
2,494 Posts
I have a '95 Vulcan and my high beam and headlamp light stay on all the time. The high and low beam seem to be working but the bulbs stay on. Does anyone have any idea what's going on.
This being your first post we are not sure if you know the headlight is on whenever the key is in the "on" position except when the starter button is engaged. Please give us a little more information about what is happening and your exact question. When you have time please do an introductory post in the Newbie section telling us a bit about your wrenching and riding experience. It always helps to know a bit about the person that needs some help with a particular situation.
 

·
Registered
Joined
·
1,623 Posts
Post up to the questions the other guys ask. It would help a lot on getting answers. Also, I'm in Bama too, North Central. Live anywhere up this way?
 
1 - 5 of 5 Posts
Top