Kawasaki VN750 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a minor oil leak that is becoming increasingly more of a problem. I can't pinpoint where the leak is coming from quite yet, but I suspect the 2 hoses coming out of the rear end of my clutch cover. All pictures are on the left side of the bike.

Has anyone seen this or have recommendations about where to look? The leak is proportional to my riding...put over a 1000 miles on in the past couple weeks and had to replace almost 2 quarts of oil to get to the proper levels again.

Yes it is filthy and makes me feel like a bad dad. Every time I clean it, it gets dirty again!

Thanks all, love the forums.
 

Attachments

·
Banned
Joined
·
10,354 Posts
First....thats the stator cover, the clutch is on the right side....those 3 screws have O rings on em that need to be replaced each time its removed (usually)....most local hardware stores will have the same in their plumbing section....on the back of that cover, is a large rubber O ring....but they rarely go,,,,could be when it was reassembled, it wasnt in its slot properly...but guessing its the screw O rings...thats a common issue...
 

·
Chasin' the blacktop
Joined
·
1,498 Posts
I've never had to pull my stator cover but I build up that kind of oil debris junk in the same place. My engine doesn't ever seem to loose oil (good for over 3000 mi between oil changes and barely moves on the sight glass) so I just mark it up to road grime and hit the car wash every 800 miles or so and blow it off.

I figure that if it's from my engine it's so little oil I'm not going to worry about it.
 
1 - 3 of 3 Posts
Top