Kawasaki VN750 Forum banner

1 - 2 of 2 Posts

·
Premium Member
Joined
·
650 Posts
Discussion Starter #1
Well, I was ll ready to fire her yesterday for the first time in many months.

I had the new tank on with my old petcock (which worked just fine mind you). I poured the gas in and watched in horror as the "drip drip drip" began from around the petcock all over the engine.

Well I drained the gas and pulled the tank. I pulled off the petcock and noticed the forward "L" is very easy to move. I noticed another thread on here that mentions that it is ok for the "L"'s to move as long as there is no pressure on them. Who knows?

I'm curious as to what could be causing the leak. I re-used the old "O-ring", but it's a rubber O-ring so I figured they don't need replacing. Mind you, this petcock is now 21 years old.

Anyhow, long story short...I had some credit at Ronayers and just picked up a new petcock for $54 and new bolts and washers to hold it in. If anyone is in need of an old petcock that may need rebuilding (or just an O-ring), I'll have an extra one shortly. :BLAM:

P.S. on this subject. Anyone ever notice a "divit" in the gas tank towards the front of where the petcock mounts? I almost seems like a little ding that would prevent a good mating surface. I looked at one of my other extra tanks and it had it as well. Thoughts???
 

·
Registered
Joined
·
226 Posts
I have a really minor leak from my petcock. Nearly ever rubber O ring I have come across needs to be replaced on this bike. Rear cylinder, right side coolant pipe, left side generator cover, etc. I'm guessing the O ring in the petcock is to blame. Anyone else think so?
 
1 - 2 of 2 Posts
Top