Kawasaki VN750 Forum banner

1 - 9 of 9 Posts

·
..have a vulcan good day!
Joined
·
4,508 Posts
Discussion Starter #1
Searched threads but unable to find this problem. Sometimes when placing right turn signal on...nothing happens. If i lean the bike towards the right (still steering straight) the signal will start blinking. Most other times signal function is fine. Yesterday, the Left turn signal duplicated the same problem (leaning bike left). I suspect either a turn signal switch malfunction or the wire harness connectors under Tank/bars. Has anyone else had similar turn signal problems ?

:(
 

·
Registered
Joined
·
3,353 Posts
that's a new one! While on the center stand, maybe you can wiggle the Turn Signal Relay and see if it is a flaky connection. Same for the harness I guess.
good luck!
 

·
romeobravo172
Joined
·
842 Posts
Ck your grounds,12 volt lights will do the strangest things with an intermitten or poor ground, trailer lights are notorious for this! I ALWAYS ck and make sure I have a GOOD ground first.
 

·
Premium Member
Joined
·
3,027 Posts
There is only so much that can be wrong with a turn signal system, because it is so simple. If the turn signals work at all, that rules out the bulbs and individual light sockets. Your problem is either in the switch, a loose connection in the wiring (either hot or ground), or a bad flasher unit. Because motorcycle handlebars turn, and the wiring has to turn with them, I have seen numerous cases where the wires rubbed against the frame or some other edge, and wore through the insulation, grounding it out. Connectors are also subject to corrosion.
 

·
Registered
Joined
·
84 Posts
I had the same issue with my turn signal on the right side. After checking the bulb, I traced the wiring from the turn signal back towards teh relays under the seat. I found I had a connection that was working loose. A few days later, I had the same issue on the left side. Same resolution. heck that our first.
 

·
..have a vulcan good day!
Joined
·
4,508 Posts
Discussion Starter #6
connectors

TYVM Wayne... will perform connectors check first. :)
 

·
Banned
Joined
·
1,620 Posts
I would guess connector under left front cover...........
 

·
Registered
Joined
·
84 Posts
That is where I found the turn signal issue on the right rear turn signal. I found the left turn signal problem a week or so later under the seat where the wires coming from the turn signal connect with the wiring coming from the wiring harness cluster.
 

·
Member? ... check.
Joined
·
536 Posts
Ya' know Tech, the weather down there isn't going to be all that great for the next few days. Why not take the time to put some dielectric grease in those connections while your searching for your electrical problem. It helps protect the connections from future corrosion and contamination. Less downtime.

Good hunting ...

~~C8>
 
1 - 9 of 9 Posts
Top