Kawasaki VN750 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
235 Posts
Discussion Starter #1
does anyone have an ignition switch for available? I think mine is kinda flaky.
 

·
2014 KLR 650!
Joined
·
3,361 Posts
If you mean where you put your key in, then just take it apart and clean it. There are pics here someplace. It's easy, just watch you don't lose the springs or the one ball bearing.
 

·
Registered
Joined
·
235 Posts
Discussion Starter #3
yeah.... did that. cleaned the contacts, stretched the springs a little. Worked great for a while. now when i turn my bars all the way to the right, bike cuts off. Checked the tension on the harness, seems ok. think there may be a short in the wiring.
 

·
2014 KLR 650!
Joined
·
3,361 Posts
Very possible. The soldered connections in the ignition housing aren't all that wonderful either.
 

·
Registered
Joined
·
235 Posts
Discussion Starter #5
I think I will go back in and remelt all the solders just for fun.....then see what happens.
 

·
Sparky!!!
Joined
·
8,697 Posts
while you are at it you can build up the contacts with solder as well, then take an ignition file to file the solder back down to make it smooth.
 

·
Registered
Joined
·
235 Posts
Discussion Starter #7
Thanks Slim, went in and did what I said I was gonna do and that did not help any. Thought it was the switch because I had been messin with it. But after further thought and troubleshooting,... think I need a front coil instead. Front pipe did not heat up near as fast as the rear.
 

·
Chucklehead
Joined
·
1,050 Posts
Take a good look at the wires that go around the neck. Mine wore through there and made the same issue. The insulation wore away and it was shorting out on the frame. Makes for an easy repair, and it;s only about six inches of wire to look over.

Just my $.02
 
1 - 8 of 8 Posts
Top