Kawasaki VN750 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter #1
What the heck! Flash flood in July in California! Had crazy rain while I was at church. My bike was outside exposed to heavy rain for over 10 minutes. Now I've got no lights period! Starts fine, runs fine.

Any ideas what happened? Did it short out? Will it come back after it dries?
 

·
Registered
Joined
·
458 Posts
I started having trouble with just my turn signal lights, noticed one of them had some water inside. Had to pop the cover off and clean up some mild corrosion then they staterd working properly again. But just 10 minutes in the rain you would think would not cause that.
 

·
Registered
Joined
·
7 Posts
I don't have a suggestion for your headlight problem, but I did enjoy watching your video, in high def. Very creative.
 

·
Registered
Joined
·
88 Posts
Discussion Starter #5
Awesome!

I don't have a suggestion for your headlight problem, but I did enjoy watching your video, in high def. Very creative.
Thanks! Glad you liked it!
 

·
If only it had 6th gear..
Joined
·
1,100 Posts
Yeah your video was the nuts. Does your headlight come on after it's running? I had a small section of wire under the seat that was bare and it killed all my lights except the headlight because it's on a different circuit. It was a 10 amp fuse that blew.
 

·
Registered
Joined
·
88 Posts
Discussion Starter #7
No the headlight and tail light don't work. Blinkers do tho but blink real fast.
 

·
If only it had 6th gear..
Joined
·
1,100 Posts
Wow. So you have no electronics other than your ignition? How about horn and tachometer. I wonder if the junction box shorted due to the rain or a main circuit in it. Something like a fusable link on a car. Just throwing things out there as I'm thinking about things....
 
1 - 8 of 8 Posts
Top