Kawasaki VN750 Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
1,067 Posts
Discussion Starter #1
Just put a new battery in my baby and noticed all my lights are on. Funny thing is the key wasn't even in the bike... Could my gremlin be in the key cluster? Bike started just about right up lol.
 

·
FREEBIRDS MC CENTRAL NY
Joined
·
16,076 Posts
Does it start without key?try unplugging ignition switch to see if lights go out
 

·
Registered
Joined
·
1,067 Posts
Discussion Starter #3
Doesn't start without the key. Guy is tracing all the wires. His initial thoughts are that its sole kind of diode.. Now he's playing with the ignition
 

·
Registered
Joined
·
1,067 Posts
Discussion Starter #5
Key wasn't even in the bike when all the lights came on.
 

·
Registered
Joined
·
1,067 Posts
Discussion Starter #6
Needs me an ignition switch boys. Who's got one. Bike will run but the key can't be all the way on. Has to be half way on and off. Also had to wires rubbing and killing my battery. That's fixed. Hopefully this ignition is the last problem for a long time.
 

·
Registered
Joined
·
1,067 Posts
Discussion Starter #8
No haven't done that. Not sure what goes into the process
 

·
2000 VN 750 Senior Member
Joined
·
2,494 Posts
No haven't done that. Not sure what goes into the process
I believe there is a whole write up on redoing your ignition switch. Do a search and I am sure it will show up. Good luck.
 

·
Registered
Joined
·
3,353 Posts
let me know when you are available Tom, and I will help you out. Bring that bad boy over my house and we will take apart the ignition puck and clen/rebuilt it together. Then we can fire up the grill, have a few beers and chill for a bit.

Anyone else in NNJ want to stop by to have any issues investigated, let me know. We might as well make a day of it....lol
 

·
FREEBIRDS MC CENTRAL NY
Joined
·
16,076 Posts
Hell I've got TONS of issues...
 

·
Registered
Joined
·
1,067 Posts
Discussion Starter #12
Gonna need more then a day to fix your issues doc lol.
 

·
FREEBIRDS MC CENTRAL NY
Joined
·
16,076 Posts

·
FREEBIRDS MC CENTRAL NY
Joined
·
16,076 Posts
Yes brother head on and at full throttle ;)
 

·
Registered
Joined
·
223 Posts
I actually had this happen a ways back, long story short I had to rig the switch on the side of the road to get home. It needed to be cleaned because it was shorting and I broke a tab on the switch case. When I got home parked it and the lights wouldn't go off. Had to disconnect the battery and when I repositioned the switch it was fine again until I replaced it. A good cleaning will fix it up just be gentle as to not snap the plastic tabs. There's two little screws on either side of the ignition switch just remove them (easier said than done they are tiny and hard to get at past the headlight and forks) slide down the black plastic case and then proceed to carefully lift the tabs over the notches. The two halves of the switch will separate be careful not to loose the tiny pieces. Clean the contacts (copper tracks) and re-assemble.
 
1 - 18 of 18 Posts
Top