Kawasaki VN750 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Recently bike will not start. I was out riding, stopped by a friends to say hello. Bike was running fine when I turned it off. Turned the key on to leave and no power to lights, horn, starter button. Took apart ignition switch had to re-solder a couple of wires. Bike still won't power up. Checked battery-(good). Fuses-(good). Checked grounds, battery to chassis and chassis to engine-(good). Any help would be very appreciated, Thank you.
 

·
Thats 'Mr' Jr Member
Joined
·
249 Posts
Similar to an event with my bike a couple of weeks ago. Here's the write-up from my post about re-locating my rear turn signals;

After checking to make sure the tail and brake lights and both new turn signals were working, I pushed the start button and nothing happened. "Dang It... What now?!

I had taken the brake and clutch handles off and cleaned them up on the wire brush of my bench grinder, so I decided this must have something to do with the clutch safety switch.
When I first got this bike I noticed that I didn't have to pull in the clutch to start it.
It looks like the plastic pin that the clutch handle pushes in was broke off, so the switch is always in the start position. I unplugged the wire harness from the switch to remove it from the bike and found the two tiny (#2 screws) that hold this switch to the underside of the clutch were seriously rusted and I almost messed them up but finally got them to turn.

Using a test meter I found no continuity between any of the three terminals of the switch so I opened it up and all of the contacts had corrosion on them. After cleaning everything up I got good readings on the meter and plugged the switch back onto the line and the bike started up just fine. Back to Home Depot where I got some stainless steel, #2x14mm, beveled head screws and reattached the switch into its place under the clutch lever and I was on my way.
 

·
2014 KLR 650!
Joined
·
3,365 Posts
It is stil;l your ignition switch and maybe it isn't pressing together well. I superglued and tie wrapped mine.
 

·
Registered
Joined
·
1,067 Posts
With mine I had to turn the key just a little before on or it wouldn't get power lol. These bikes are very picky
 
1 - 5 of 5 Posts
Top