Kawasaki VN750 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1 (Edited)
Hi all this is my first post. I have a few problems. I purchased my bike about 1 year ago. It had been sitting. I got it running somewhat and then it sat again. I sent it the shop almost a month ago now and they got it running. Said it needed a carb kit and a wire fixed and the pet cock fixed. Now after he got it running the hard lines coming out of the cylinder heads are leaking. Is that just a regular 14mm o ring or is it a square cut o ring? And I was told that a regular round 14mm o ring should seal it even if it was a square cut in there. Hope all the info I gave helps!
 

·
Registered
Joined
·
8,540 Posts
It's just a round o-ring. I ended up using a 5/8" or so.

Good idea to coat them with grease, there's some corrosion that occurs there with the steel tube in the aluminum head.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Any other tips? The shop said they “Couldn’t get it to seal. Still pissing bad”
 

·
Registered
Joined
·
8,540 Posts
Any other tips? The shop said they “Couldn’t get it to seal. Still pissing bad”
Make sure everything is clean and as smooth as possible, and use a generous coating of waterproof grease.

I've noticed a lot of the coolant tubes with fairly heavy corrosion and pitting that might cause sealing problems. Make sure there's no white clots of corrosion stuck in the head. If the tubes are pitted bad, the pits will have to be filled or the tubes replaced.

I think you can even double up on o-rings if needed.
 

·
Registered
Joined
·
450 Posts
Funny I had to read most of the replies to figure...its a water leak!!Thought at first you were talkin oil!!
 
1 - 5 of 5 Posts
Top