Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums - Reply to Topic
Electrical
Where does this wire go?
Includes Electrical mods, Lights, Stator,
Rectifier, Diagrams, etc

Thread: TPE Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Once registered, your User Name"cannot be changed". We can make exceptions within 7 days, but after that, it is set in stone.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-28-2014 12:54 AM
VN750Rider/Jerry
Quote:
Originally Posted by Stones750 View Post
I finally got the replacement back, not happy at all. The more I thought about things the more I wondered how a stator works fine for a year if it made contact with the rotor. I investigated and my rotor in fact has no scratches or rub marks at all. I can say that I will never go to TPE in the future or recommend his services. The photo is the quality stator I received after a month of waiting. It looks nothing like what he sent me the first time and it definitely is not the same core I sent back. I don't really want to risk trashing my rotor by trying to use it. Electrosport or Ricks here I come.
Not good. I have seen TPE stators and other electrical parts highly recommended not only on here, but on other forums. Anybody else have problems with them? (the actual part, not shipping or customer service)
08-27-2014 07:12 PM
Stones750 I finally got the replacement back, not happy at all. The more I thought about things the more I wondered how a stator works fine for a year if it made contact with the rotor. I investigated and my rotor in fact has no scratches or rub marks at all. I can say that I will never go to TPE in the future or recommend his services. The photo is the quality stator I received after a month of waiting. It looks nothing like what he sent me the first time and it definitely is not the same core I sent back. I don't really want to risk trashing my rotor by trying to use it. Electrosport or Ricks here I come.
08-22-2014 05:52 PM
VN750Rider/Jerry I just got a notification from USPS, complete with tracking #, that my stator has shipped. I have not sent him my old one yet, he already had a VN750 stator done. I'll send him the old one when the new one gets here.
08-22-2014 04:41 PM
Stones750 *Update

I finally heard back from Tim, he had some personal issues that kept him from getting it done. Turns out somehow the rotor made contact slightly and caused the failure. He has still covered it which is amazing.
08-19-2014 09:39 PM
Chuck A. I can say we have had some strog summer time storms come through the state lately. Also, I talked with him when he did my stator 2 years ago and he said summer time is major work. He does all kinds of vehicle alternators and electric motors also.
08-19-2014 09:24 PM
wib714 I'm kicking 20,000 plus miles on my rick's stator. thats what I got out of my original oem 23,500. I'm doing the stator mod now just in case but would do a tpe in the future if needed and had time to wait
08-19-2014 05:43 PM
VN750Rider/Jerry I ordered a stator from him due to recommendations on more than one forum. He does not answer the phone, said something about being busy repairing the roof. After several emails, he finally sent me a Paypal invoice last Friday, and I paid it. Money has been taken out of my account, haven't heard anything yet. Hopefully it will be here in the next 2-3 weeks, so I can get everything back together for riding season. I am NOT going to spend $400 on a new oem stator, and I'm not going to risk one of those cheap eBay ones. There is always some risk with parts like that, but it is more of a big deal with the Vulcan 750 because of the amount of work involved.
08-15-2014 01:24 PM
kyledk I had the same issue, I contacted him two weeks before I needed the stator and ordered it. I went 13 days before he replied and 16 or so days after he told me he shipped it I final received the invoice. I sent him 5 emails and called 9 times over 3 days because I needed to know if I should overnight ship a stator from ricks (I did). I ended up receiving his stator the same day as I got the one from ricks and installed the TPE because of the quality reviews.

In short, if you've got the time to wait and play email tag the product should show up but don't order it in a hurry and expect to receive it quickly. On that note the stator I just installed from him works like a charm, I've only got 70 miles on it yet though.


If you need a stator ASAP I have the extra one from RICKS I'm selling (see thread).

(P.s I also spent over 2 months this season without riding, but do to a failed factory stock stator)

Good luck!
08-15-2014 01:08 PM
Stones750 Well here's the situation, I emailed him back in July around the 16th about my stator that he rewound, it went great until a little down the road. Almost 1 year later my stator is toast. While this is rare from TPE from what I can tell I have that luck. He was very quick to respond and helpful at first. I shipped it back and he confirmed he received it on the 25th of July, stating he would get on it ASAP and keep me informed. After that I sent about 5 emails over the last three weeks trying to figure out the situation. All of which were ignored. So yesterday I sent one from my separate email account asking about stator turn around time, I got a reply in about 30 minutes. So giving the benefit of the doubt (maybe my emails were going to spam) I informed him of what was going on. He responded saying it should have been done and returned and he would look into it. Since then I haven't heard a word. Kind of seems I am out a core/stator and have missed the last month of summer riding due to a bad product.
08-15-2014 11:45 AM
kagaku I just ordered a stator from TPE this morning. He mentioned it should ship same day and that he had a couple in stock.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome