Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums - Reply to Topic
Wheels, Suspension and Brakes
Everything to do with wheels, tires,
suspension, forks and brakes

Thread: Front Pads Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Once registered, your User Name"cannot be changed". We can make exceptions within 7 days, but after that, it is set in stone.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-25-2008 10:53 PM
750Doug Mine squeak.
05-25-2008 10:44 PM
googy00 mine squeak too with plenty of material left.....may be hardness of pads?
05-25-2008 12:59 AM
borto1990 My bike is an 04 that I bought with 3K on it. squeeks when I am just about to a stop.. been doing it since day one. played around with the brakes for a few days when I first got it.. I tub ground my rotors and stoned the groves out of the pads and no help. I just learned to live with it. gets kind of annoying sometimes but I hardly notice it anymore.
05-24-2008 01:15 PM
Knifemaker Front brake pads usualy go at more like 10-15 thousand miles...but it does depend on how hard you use them.

They should not squeek when you are not applying the brakes.

Someone here can tell us, but I think the pads have some kind of "wear indicatior" to know when they need replacing.


KM
05-24-2008 01:12 PM
Gemguy
Front Pads

Is it possible with normal riding that I would need front brake pads after only 4,000 miles? If so, that may be the source of my front end squeek. Any opiniond appreciated.

Gemguy

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome