Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums - Reply to Topic
Electrical
Where does this wire go?
Includes Electrical mods, Lights, Stator,
Rectifier, Diagrams, etc

Thread: Wanted to share a stator story. Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Once registered, your User Name"cannot be changed". We can make exceptions within 7 days, but after that, it is set in stone.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
09-09-2007 01:32 AM
tonenuff Sorry to hear that bro! Had to do the stator in mine also, got it on Ebay (RM Stator Inc). Did that and a MF Big Crank battery and so far, so good!
09-09-2007 01:06 AM
hyperbuzzin
Quote:
Originally Posted by thisguyinkc View Post
So I have another Electrosport stator awaiting a cold weekend. I mainly wanted to say to say thanks for all of the people on this site that provided me with much needed information.
There have been a few people here who've mentioned the Electrosport quality seeming to be on the decline. Have you contacted Electrosport about the issue?
09-08-2007 10:45 PM
mstbone67a cool a fellow kc'er!! Down in Olathe here.. Gotta do my stator also.
09-06-2007 11:27 PM
thisguyinkc
Wanted to share a stator story.

At something north of 25000 miles on a hot day (before I knew of this forum) I lost my stator, probably in traffic at a stop light. I didn't have any mods (r/r reloc, m/f batt, etc.) done and it cost me mucho time to partial/pull the engine to replace the stator. I could not have done it without the information on this site and I STILL didn't do it right. My new stator had the wiring harness clamp situated in such a way as to allow the stator wires to get into the rotor and chaffed the wires. Right now they are repaired and I am hoping that the repair will last until the first snow and I will change the stator AGAIN and be MUCH more careful. So I have another Electrosport stator awaiting a cold weekend. I mainly wanted to say to say thanks for all of the people on this site that provided me with much needed information.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome