Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums - Reply to Topic
Electrical
Where does this wire go?
Includes Electrical mods, Lights, Stator,
Rectifier, Diagrams, etc

Thread: CDI help Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Once registered, your User Name"cannot be changed". We can make exceptions within 7 days, but after that, it is set in stone.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
10-12-2013 12:38 PM
Big Nick
Cdi Igniter

It's a sealed unit, though mine seems to have been opened quite a bit.
It's stuffed and have bought a low mileage replacement.
On to other repairs now,but here is a picture of the internals of the CDI.
09-01-2013 01:08 PM
Big Nick Thanks mate, I've gone with a low mileage replacement,from a Company called Junkyard dog. So when the mail comes in, and I finish my other list of repair maintenance and general detailing, I'll let you know how the story ends.
Ps do you have any problems over there with dictators, trying to tell you what size bike your welcome to ride?
08-27-2013 04:18 PM
slimvulcanrider
Quote:
Originally Posted by Big Nick View Post
Well I bought an old Vn Kawasaki, Live Long and Prosper! If fixin the cdi igniter box works out. I could be almost smiling. Rusty brakes,lots of corrosion,crappy tyres, and a good riding position. I like the pegs,19" front wheel, the promise of 40mpg, a fair set of bars, and a good figure. So has anyone come across an aftermarket Cdi that's as common as grass and cheap as can be, that can be wired in to do a good job? If so, let us in on the secret. Big Nick.
I only know of one CDI that will work on these bikes, and it aint common, cheap, or user freindly to install.. you have to import it in from Germany, make a custom harness for it, and then flash it with the VN750 timing specs.

Ignetech DC-CDI-P2 ICB
08-25-2013 12:15 PM
Big Nick
Big Nick

Well I bought an old Vn Kawasaki, Live Long and Prosper! If fixin the cdi igniter box works out. I could be almost smiling. Rusty brakes,lots of corrosion,crappy tyres, and a good riding position. I like the pegs,19" front wheel, the promise of 40mpg, a fair set of bars, and a good figure. So has anyone come across an aftermarket Cdi that's as common as grass and cheap as can be, that can be wired in to do a good job? If so, let us in on the secret. Big Nick.
05-09-2013 09:11 PM
hellsoldier35 OK UPDATE my Clymer manual is wrong on the CDI test. The service manual that Wolfie sent me says test the CDI on Rx1k and the Clymer manual says rx10 and after retesting my CDI at rx1k its good passed all test so my rear ignition coil was the culprit after all now I just need to finish my bike up ASAP and I might be able to get it legal this year and not wait until next year sweetness thanks a ton wolfie you are the man after all.
05-09-2013 08:35 PM
hellsoldier35 well I hate to say it but I think I know why my rear ignition coil went out. I looked at the service manual Wolfie sent me and in that manual page 269 it shows my rear ignition coil wire hook up and mine is hook up backwards not sure why but that might be the cause of my rear ignition coil and CDI to go bad I'm guessing. I'm now hoping everything else is fine I'l be testing everything else on Saturday so I'll post the results.
05-09-2013 07:19 PM
Wolfie Files sent btw....



05-09-2013 06:25 PM
hellsoldier35 Well got to work on the bike today and did some resistance testing my rear ignition coil is bad the one side were the plug wire comes out looks burnt inside the ignition coil and it failed the secondary test but luckly I have a extra ignition coil so thats been replaced. Now my question is what couldve caused this coil and CDI to go out at the same time. Looks like the coil got a shock from something. Ill be testing the stator, rectifier, alternator and anything else next time probably Saturday.
05-09-2013 12:17 AM
Wolfie Just PM me yer email addy....I'll send you my Hi-res wiring diagrams...



05-08-2013 11:49 PM
hellsoldier35 Im about 2 hours north of bowling green up by Owensboro. Right now I have to wait until next month to buy a different CDI monies tight bought a lot of stuff this month for it already I do appreciate the offer though.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome