Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums - Reply to Topic
Equipment
Everything related to equipment
Includes backrests, luggage racks, windshields,
floorboards, pegs, and riding gear

Thread: Am I some kind of dope? Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Once registered, your User Name"cannot be changed". We can make exceptions within 7 days, but after that, it is set in stone.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
03-18-2011 10:35 PM
Knifemaker
Quote:
Originally Posted by flitecontrol View Post
Got a torque wrench?
LOL. Seriously....




KM
03-18-2011 09:18 PM
clock152
Quote:
Originally Posted by scuba View Post
I gave up on doing anything on my bike. I broke too many things while trying to modify this or that. I broke the nuts off while trying to install a drivers backrest today. Didn't know my own strength when trying to tighten them.
I feel ya!.. my well abused 92' has more than a few busted bolts.. some I got out some .. well.. JB weld is my best bud!
03-18-2011 09:05 PM
flitecontrol
Quote:
Originally Posted by scuba View Post
I gave up on doing anything on my bike. I broke too many things while trying to modify this or that. I broke the nuts off while trying to install a drivers backrest today. Didn't know my own strength when trying to tighten them.
Got a torque wrench?
03-18-2011 08:08 PM
OlHossCanada
Quote:
Well it sure is a jam nut. I've gone at it with every tool I have and it doesn't budge.
Try clamping the jam nut in a big bench vice and lever the mirror stem around.
03-18-2011 07:26 PM
scuba I gave up on doing anything on my bike. I broke too many things while trying to modify this or that. I broke the nuts off while trying to install a drivers backrest today. Didn't know my own strength when trying to tighten them.
03-18-2011 07:12 PM
Papa Smurf Well it sure is a jam nut. I've gone at it with every tool I have and it doesn't budge. Used up most my WD40 too. Heh. Well, tomorrow I will either break it or get it going. If not, I am buying these (at the rec of some folks on here): http://www.jcwhitney.com/cruiser-sty...1342y1994o60j3

Jam nuts on these new ones better not give me the same issue...
03-09-2011 02:07 AM
kc_matt Yea,

The two jam nuts (one by the base, one up by the mirror) loosen so the arm twists freely by itself. Loosen the nut, get the arm to the angle you want and tighten the nut down.

03-09-2011 12:30 AM
Papa Smurf Is that the hexagonal nut on the mirror piece? I want to make sure before I give it a strong go with the wrench since it seems pretty tight.

Thanks!
03-09-2011 12:08 AM
slimvulcanrider try adjusting the jam nut
03-08-2011 11:46 PM
Papa Smurf
Am I some kind of dope?

Well, I kind of already know the answer. So after my right mirror mount broke I got the part number and ordered it online. Received it and it fits like a glove. Problem is when I screw in the mirror it tightens up facing the opposite direction it should. It needs another 1/3rd turn, but I feel I will strip/break it if I go that far.

What am I doing wrong? The mirror only screws in one way. I thought I would ask before I tried something that could break stuff like taking my big wrench to it.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome