Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums - Reply to Topic
Carbs and Fuel System
From the gas tank to the carbs
All fuel system discussion

Thread: petcock Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Once registered, your User Name"cannot be changed". We can make exceptions within 7 days, but after that, it is set in stone.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
12-22-2010 06:12 PM
ksmnet
Quote:
Originally Posted by electrum View Post
my 96 has res-on-off.
the other day i put it on off and let it run thinking it would empty out the carbs... it ran for 20 minutes in off and i gave up waiting and put it back to on.

how long should it run in 'off'... or is my 'off' not doing what it says?
I suspect "Off" is not doing what it says. My '01 had "Off" "On" and "Res", and "Off" would run for a minute or two, then it would die, which is how it is supposed to work - empty the carb bowls, then quit. I have always been in the habit of turning the petcock off when the bike is parked. That is until my current bike, which has EFI, and no petcock.
12-22-2010 05:26 PM
OlHossCanada
Quote:
Originally Posted by electrum View Post
my 96 has res-on-off.
the other day i put it on off and let it run thinking it would empty out the carbs... it ran for 20 minutes in off and i gave up waiting and put it back to on.

how long should it run in 'off'... or is my 'off' not doing what it says?
The first 3 or 4 model years from `85 to about `88 had petcocks with PRI(me), ON and RES(erve). The PRIME position is supposed to fill the carbs without vacuum being applied. For some reason Niteriders petcock does not allow this to happen.

Quote:
I have had the tank off and gone through the positions and none flow gas without the vaccuum being put to the hose. I even had the petcock apart and could not figure it out. - Niterider
All later vn750 models from 1989- 2006 have a petcock with OFF-ON- RES(erve) positions. Vacuum must be applied to the middle nipple to get fuel to flow from the 2 end nipples.
12-22-2010 02:11 PM
kc_matt Check out this thread

Quote:
Originally Posted by Adrianmur View Post
...it does not have the vacuum thingy but it has an OFF position... ...This is the information I found in the box:
---------------------------------------------
- Model: XT200
- ITEM: COCK FUEL
- PART No: 15A-24500-02
---------------------------------------------
it has only one pipe that go to the Carbs, so I used a T to connect it to both carbs, It works perfectly, I thought it wouldn't send enough fuel to both carbs but it does.
12-22-2010 12:28 PM
electrum and a secondary question.... i've never liked the vacuum on the petcock, seems like a fix for a problem that didn't exist. whats so hard about flipping the petcock to off when i park. been doing that for 30 years on my other bikes and never had a problem.

is there a direct replacement petcock that i could swap in that does not have the vacuum requirement, just a normal res-on-off position?

i could get rid of some more vacuum lines and not worry about coming out to the bike and finding it in a pool of gas from a broken diaphragm in the petcock. (this seems to be common on new bikes, saw 2 in the parking garage this summer like this, i assume from their vacuum petcocks).
12-22-2010 12:21 PM
electrum my 96 has res-on-off.
the other day i put it on off and let it run thinking it would empty out the carbs... it ran for 20 minutes in off and i gave up waiting and put it back to on.

how long should it run in 'off'... or is my 'off' not doing what it says?
12-22-2010 11:42 AM
niterider You are right, it makes no sense. I have had the tank off and gone through the positions and none flow gas without the vaccuum being put to the hose. I even had the petcock apart and could not figure it out.
12-22-2010 10:18 AM
fergy Huh. On my KZ's, PRI was prime, and it would fill the carb bowls without engine running and vacuum. I wonder if someone rebuilt your petcock Niterider? Maybe the 750 PRI needs vacuum. That doesn't make any sense though, at least to me.
12-21-2010 10:35 PM
DelmarvaBiker
Petcock

For what it's worth, after reading what you all wrote, I had to go double check what was written on my petcock. I have Off, On, and Res. Off is off as I can run my carbs dry. On is vacuum controled. And reserve works as it is suppose to when I run out of fuel in the On position. Giving me enough to find a fuel stop to refill. I'm not sure about the Pri as I do not have that on my petcock.
12-21-2010 11:35 AM
niterider pri=prime mine still does not flow in prime unless it has vaccuum applied to the on off hose.
12-21-2010 10:35 AM
FlacoLove deleted
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome