Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums - Reply to Topic
Electrical
Where does this wire go?
Includes Electrical mods, Lights, Stator,
Rectifier, Diagrams, etc

Thread: Front brake light switch - losing my mind Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Once registered, your User Name"cannot be changed". We can make exceptions within 7 days, but after that, it is set in stone.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
03-02-2019 09:30 PM
Jason Pittenger I would agree that there is a wiring problem after the switch. If it's getting that hot, something must be shorted to ground.
02-24-2019 06:55 PM
Thorn I would bet there's a short to ground between the switch and the tail light. I think there's a set of bullet connectors under the seat that goes to the tail light that might be getting pinched against the fender. Corroded terminals would decrease current in the switch (but may create localized heat at the corrosion). A short after the light would have no effect since that wire goes to ground anyway.
02-24-2019 01:41 PM
moreruffage Doing some reading, looks like I'll check the relay too.
02-24-2019 01:37 PM
moreruffage Stumbled upon the thought you guys might be right about current.

The most recent switch was stuck recessed, and I got it released and it tested fine. Then sometime later that day it stopped working.

Few weeks later now and I found time to take another look and the switch seems fine and I had it off mount, hanging in space, key on and manually triggering. Looks good. Weird, right? So, I went to get a can of wd40 and maybe lube the detent a bit and when I got back and lifted the switch up, I about burned my finger off. Yeoww!

I don't think it should be that hot. Like, ever.

So now the question is why? I can certainly get in there and clean up the contacts on the bulbs, but what else could it be?
01-15-2019 02:38 PM
SkyPilot Pulling too much amperage due to corroded connections and/or bad grounds will melt headlight sockets for sure.
Might be enough draw in that brite brake filliment to futz the internal switch contacts as well.
Check the bulb socket and ground(s)
01-14-2019 02:43 PM
Jason Pittenger Check the wires for shorts. Shorts are bad, but pants are acceptable.
If there is a short, the excess current could overheat the switch.
An overheated switch could physically bind and stop actuating.

In case you are wondering, wire pants are actually a thing!
They prevent shorts.
https://www.amazon.com/Speaker-Wire-.../dp/B004YUIW1Q
01-13-2019 05:17 PM
TonyO The two mechanical failures could be caused by a misalignment somewhere. Could the mounting location be damaged so it puts unwanted (sideways) forces on the switch mechanism?
01-13-2019 12:13 PM
moreruffage
Front brake light switch - losing my mind

I bought a 1999 vn750 in October and have gone through 3 front brake light switches. First one, the switch detent locked down and wouldn't toggle, the second one some circutry fried inside and the third the detent locked down again. Each time the switch doesn't last more than a week.

Argggh! Anybody with any thoughts here?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome