Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums - Reply to Topic
Carbs and Fuel System
From the gas tank to the carbs
All fuel system discussion

Thread: Fresh rebuild leaking like a sieve Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Once registered, your User Name"cannot be changed". We can make exceptions within 7 days, but after that, it is set in stone.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
07-29-2017 09:30 PM
Spockster Floats could be stuck, sometimes firmly rapping the carb bowl with a plastic screwdriver handle can free them.

Always shake the float when it's removed to be sure it hasn't filled with gas.
07-29-2017 08:49 PM
Knifemaker Other than not replacing the needle valves and seats?

Float height could be the culprit, either way looks like you'll need to yank the cabs again..
07-29-2017 03:41 PM
Nate Swanson
Fresh rebuild leaking like a sieve

Hey all, been doing some reading on this issue, but haven't nailed down anything definitive. I just rebuilt my carbs, ear shaved, rejetted, etc. Everything rubber was replaced, o-rings, diaphragms, fuel lines. Got the bike running, and now my carbs are leaking like crazy. It looks like the leak is coming from the float bowls. When I rebuilt the carbs I did not replace the needle valves as the rubber still felt great, nice and sharp. One thing I'm seeing in some of the rebuild threads that I totally missed and neglected to do was to adjust the floats. Could this be what is causing the leak, or is there some other stupid mistake I could have made?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome