Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums - Reply to Topic
Equipment
Everything related to equipment
Includes backrests, luggage racks, windshields,
floorboards, pegs, and riding gear

Thread: Luggage rack installation problem Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Once registered, your User Name"cannot be changed". We can make exceptions within 7 days, but after that, it is set in stone.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-31-2017 03:22 PM
bassace Finally got my luggage rack installed and every thing back on. It is a very snug fit requiring me to use flat screws rather than a hex head bolt. Still seemed a lot more snug of a fit than it should have been.

I also installed an Emgo top case which is removable if I don't want to take it with me or need to bring it inside. The only issues are I have to remove the case to open it as it opens from the back towards the front. Lastly I need room between the rear of the case and the sissy bar in order to open/remove the case. I secured it to the rack with thick 4" mending plate.

I have hard side bags t o put on as well. Looks like the factory hangers just arrived on the ole' porch step.
08-30-2017 06:23 PM
eusjma
Quote:
Originally Posted by eusjma View Post
I remember having to force mine in when I installed my rack. It was definitely tight getting it in place.
Adding to my own post here...

I should have also pointed out that my rack (bought used) was 'tweaked' slightly. Meaning there was a bit of an unevenness (sp?) in the parts that bolted it to the fender/frame. That could have been the reason my toolbox had a little issue getting in place.
08-30-2017 05:47 PM
Knifemaker ^Ditto...had no problems with mine. It's quite possible the bolts you got with the rack aren't the original ones.
08-30-2017 12:49 PM
Drew M. I have a luggage rack on mine. The rack was a very small pain to install, but the tool box went right back on. I have taken the rack and the box off a few times, to install a Mustang seat, to put an extended back rest on, and recently I was installing additional break lights and took the box and seat off so I could see better. It has always gone right back in. Its really odd that everyone's factory parts are that different. I'm glad I didn't have to deal with it.
08-30-2017 12:35 PM
eusjma I remember having to force mine in when I installed my rack. It was definitely tight getting it in place.
08-30-2017 11:12 AM
bassace I just installed a used luggage rack onto my Vulcan, but I can't get the tool box back into place. I had trouble with bolts first, I had to remove all washers, etc. Now the issue is that the bottom corners of the box hit the bars for the luggage rack. I don't want to cut on the tool box. Anyone else have this issue? I'll try to take pictures tonight.
02-12-2017 06:05 PM
Chris and Shim I don't remember in all my reading here that I'd come across anyone speaking of how tight a fit it is so I wanted to see if anyone else experienced the same thing. Now, if I could only find a certain something else as tight as this! But I won't speak about that, lest I offend someone with more tender sensibilities.
02-12-2017 05:55 PM
eusjma Mine goes in pretty tight as well. Maybe not as tight as yours sounds - but I had to force it in some.
02-10-2017 07:38 PM
NIBiker
Luggage rack installation problem

Quote:
Originally Posted by Chris and Shim View Post
Ok, so I've got new bolts and the rack is in all nice and snug. Now the issue is that the black, plastic tool box (whatever it is called eludes me at the moment) will not fit. The four rack side bolts are SNUG but the tool box is wider than the distance between the bolt heads by almost 1/4" so it won't slide into place. The new bolt heads are the same size as the old bolt heads and the new bolts are a tad longer but not too long as to bottom-out up against whatever is inside. Comments?


I used 6mm by 25mm long stainless button headed Allen screws for mine, the threads in the alloy side bars that it bolts to art great so go easy, one was stripped on mine so I fitted 6mm helicoils to all 4 and all is good, the toolbox will go in past them!
Good luck!
Neill[emoji6]


Sent from my iPad using Tapatalk
02-10-2017 09:45 AM
jgs000 just use the two bottom bolts on the back rest or use flat head bolts if you can find them.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome