Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums - Reply to Topic
Wheels, Suspension and Brakes
Everything to do with wheels, tires,
suspension, forks and brakes

Thread: Front brake line issue Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Once registered, your User Name"cannot be changed". We can make exceptions within 7 days, but after that, it is set in stone.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
09-05-2016 03:12 PM
evulcannibal
Quote:
Originally Posted by One1 View Post
New cables came in last week. Put one on and one for spare. Worked great. Well worth $15 on ebay. With 3 bikes to keep up spare anything is good.
Do you have three vn750s or two vn750s and a different bike?
I was just curious since your sig says sold after your 94 vn750. Don't know if you meant gold or sold.
09-04-2016 02:04 PM
thtanner
Quote:
Originally Posted by One1 View Post
New cables came in last week. Put one on and one for spare. Worked great. Well worth $15 on ebay. With 3 bikes to keep up spare anything is good.
Any time you see people selling grab bag boxes here, I try to grab them. After a few years I had a whole spare bike in parts/electrics, lol
09-04-2016 01:04 PM
One1 New cables came in last week. Put one on and one for spare. Worked great. Well worth $15 on ebay. With 3 bikes to keep up spare anything is good.
08-25-2016 06:16 PM
One1 Ordered 2 used cables off ebay for $15 shipped. If one fails I'll have a spare.
08-24-2016 12:14 PM
One1 Thank you this is the one that Sat for 10 years before I got it a month ago so I guess it could have. I blew a lot of black sludge out of it a few weeks ago before it locked up yesterday.
08-24-2016 09:16 AM
OleDirtyDoc
Quote:
Originally Posted by Knifemaker View Post
Replace the hose. It's possible the inner wall collapsed and is blocking it up.
Yup yup
08-24-2016 08:55 AM
Knifemaker Replace the hose. It's possible the inner wall collapsed and is blocking it up.
08-24-2016 12:52 AM
One1
Front brake line issue

Today when I was riding along my bike became very slow and i pulled over to see my front left brake caliper smoking. The front brake was locked up. After a while it released so I rode home and took the hoses off, master cyl, and calipers and rebuilt them. I noticed when I removed the hose from the caliper and bleeder screw there wasn't any fluid coming out so I tried to blow through the hose at both ends of the loops and no air would pass.

There isn't a check valve or anything right? It's just a straight through hose is it not? I can't get it to release any flow through. I tried degreaser, carb cleaner, everything I could think of. Any ideas?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome