Oil Pressure Light - Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums
Engine / Exhaust / Cooling
\ From the radiator, through the case and out
the exhaust. If it has to do with the cooling,
engine or exhaust, discuss it here!

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-09-2016, 02:01 PM Thread Starter
Senior Member
 
Mcneuby's Avatar
 
Join Date: Jun 2010
Location: Close to Peoria Illinois
Posts: 509
iTrader: (18)
 
Oil Pressure Light

Yesterday I was out riding. I noticed that my oil pressure light was on. I shut it down, but I was out away from anything. After a couple minutes I started it up and still no oil pressure. I again shut it off. I was trying to decide if I was going to have to walk it back or what to do. I thought give it one more try, so i started it again. This time the oil pressure light went off. Keeping an eye on it I rode it home. This morning the light out just as soon as I start the engine. What should I be checking? There is plenty of oil, It has been a couple months since I changed it, the filter is tight no leak there. I don't know if it is safe to ride it or not. Is there any thing else I should be checking?

Mcneuby

New to me 2004 15k Last liscened in 2011. Stock as they come.
Mcneuby is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-09-2016, 03:31 PM
..have a vulcan good day!
 
WilliamTech's Avatar
 
Join Date: May 2011
Location: Pensacola, FL.
Posts: 4,508
iTrader: (17)
   
Question

Quote:
Originally Posted by Mcneuby View Post
Yesterday I was out riding. I noticed that my oil pressure light was on. I shut it down, but I was out away from anything. After a couple minutes I started it up and still no oil pressure. I again shut it off. I was trying to decide if I was going to have to walk it back or what to do. I thought give it one more try, so i started it again. This time the oil pressure light went off. Keeping an eye on it I rode it home. This morning the light out just as soon as I start the engine. What should I be checking? There is plenty of oil, It has been a couple months since I changed it, the filter is tight no leak there. I don't know if it is safe to ride it or not. Is there any thing else I should be checking?

Mcneuby
Highlighted above happened to me.....rode home 'bout 2 miles....no further problems developed.
Pulled filter, nothing but some oil as expected......then pulled
Oil Presure switch, started bike, NO OIL. I was done.
Internal Oil pump $hit the bed !

Might try Seafoam & an Oil & Filter change.

hope this helps...........

'86 VN750 13,700 mi -Stock
-Purchased 2008 w/8800mi
Replaced ALL Cables . Kuryakyn LED Voltmeter
SilverStar Ultra 9003/HB2 H4 Headlamp, Jardine Fwd Controls,
Iridiums DPR7EIX-9 & Wires, Tuxedo Mod, Coil Mod, P/U Sensor Mod, Fork Seals,
Splines Lubed - 11/4/2012 - MF AGM Battery
Additional Flashing LED Brake Light on Trunk
Dampers went out @ 13+K !
After TOC MCCT's..... so amazingly quiet I discovered a rattling heat shield on my stock exhaust !
...have a vulcan good day!
WilliamTech is offline  
post #3 of 5 (permalink) Old 06-09-2016, 04:00 PM
Super Moderator
 
Join Date: Feb 2013
Location: SW Florida
Posts: 2,457
iTrader: (5)
 
air bubble in the filter can cause this.. make sure to use a filter with anti-drainback valve..

failing oil pressure switch...

intermittant short of pressure switch wiring (usually up near the neck)

2005 VN750

Sold 11-27-17
michiganteddybear is offline  
 
post #4 of 5 (permalink) Old 06-09-2016, 05:58 PM
Senior Member
 
Spockster's Avatar
 
Join Date: Nov 2012
Location: WV
Posts: 6,629
iTrader: (5)
   
My oil light was coming on during warmups one season, it would always go back off if I kept the rpm up. After I ran seafoam for a sticky valve, the oil light blinking went away. Ran about 300 miles with the correct amount of seafoam/oil, then changed oil.

2003-21k mi
Shaved w/UniPK92+Stock Jets-TPE/MOSFET-Shinko Tires-AGM batt-bags-chrome-LEDs...more
__________________________________________________ ____________
Repair Manual: http://www.mediafire.com/file/mj7z81..._Catalogue.pdf

Owner's Manual: http://www.mediafire.com/file/nscb5f...ers+Manual.pdf
Spockster is offline  
post #5 of 5 (permalink) Old 06-09-2016, 06:03 PM Thread Starter
Senior Member
 
Mcneuby's Avatar
 
Join Date: Jun 2010
Location: Close to Peoria Illinois
Posts: 509
iTrader: (18)
 
Oil Pressure

Thanks for your replies. I had the bike out for about an hour and a half today. I kept a close eye on the oil light and there was no problem. It runs like there was never a problem. I guess I will keep riding and keep an eye on it. We are in for a hot week end here in central Illinois. Saturday it is supposed to be up close to 100 degrees. Usually this time of the year we are in the high 70s to the mid 80s.
Climate Change?

Mcneuby

New to me 2004 15k Last liscened in 2011. Stock as they come.
Mcneuby is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Once registered, your User Name"cannot be changed". We can make exceptions within 7 days, but after that, it is set in stone.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome