coolant in oil problem - Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums
Engine / Exhaust / Cooling
\ From the radiator, through the case and out
the exhaust. If it has to do with the cooling,
engine or exhaust, discuss it here!

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-16-2011, 08:45 PM Thread Starter
Junior Member
 
Join Date: Mar 2011
Posts: 1
iTrader: (0)
 
coolant in oil problem

I am a new owner of a 93 Vulcan 750. it had been in storage for a while and i went through doing some basic maintenance on it. Changed the oil and found it was thin and cloudy. Checked Cooling system there was no coolant in it. Topped off coolant levels, Filled my new battery with acid and let charge over night. Came in the next day and Filled fuel tank with fuel and started the bike. Started quickly after having not been run, and smoked some which also cleared up quickly. engine did not skip and had quit smoking after the first min of running. then i noticed something dripping from under it found leaking where the wiring from the stator comes out of the side cover and also oil was very milky looking. I shut the bike down and am currently trying to figure out if it is the O-ring at the water pump or if i may have a more serious problem.
Jimmy is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Once registered, your User Name"cannot be changed". We can make exceptions within 7 days, but after that, it is set in stone.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome