no oil pressure - Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums
Engine / Exhaust / Cooling
\ From the radiator, through the case and out
the exhaust. If it has to do with the cooling,
engine or exhaust, discuss it here!

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-17-2018, 05:29 PM Thread Starter
Junior Member
 
Join Date: Jun 2018
Posts: 8
iTrader: (0)
 
no oil pressure

After getting the engine out and with the side covers off, I can see that the oil pump is turning and the chain that drives it is intact, what else could cause the pressure to drop to nothing, could it be an internal oil ling broken? RCM
rcm243 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-17-2018, 05:41 PM
Senior Member
 
Spockster's Avatar
 
Join Date: Nov 2012
Location: WV
Posts: 6,490
iTrader: (5)
   
Did you check the pressure by putting a gauge at the oil switch? ... Yes, you did ... https://www.vn750.com/forum/31-engin...-pressure.html

It's possible the pump itself is just worn out. The gear fit is very precise and too much clearance is what makes them fail to pump.

There's been some trouble with oil changes and needing to burp the filter to turn the oil light off, but I don't know if that can also stop pressure from building in the engine. (wouldn't think so) Have you cranked it any with the oil sender fitting open, nothing threaded into it? It would suck to find out it needed burped, but at least you wouldn't have to split the case.

2003-21k mi
Shaved w/UniPK92+Stock Jets-TPE/MOSFET-Shinko Tires-AGM batt-bags-chrome-LEDs...more
__________________________________________________ ____________
Repair Manual: http://www.mediafire.com/file/mj7z81..._Catalogue.pdf

Owner's Manual: http://www.mediafire.com/file/nscb5f...ers+Manual.pdf
Spockster is offline  
post #3 of 3 (permalink) Old 08-17-2018, 06:01 PM Thread Starter
Junior Member
 
Join Date: Jun 2018
Posts: 8
iTrader: (0)
 
It was ok and the next time I started it the light was on and I put a gauge in it , no pressure, I wouldn`t think the pump would go quickly because of wear, I`ll find out when I split the cases.
rcm243 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Once registered, your User Name"cannot be changed". We can make exceptions within 7 days, but after that, it is set in stone.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome