Speedo not working - Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums
Wheels, Suspension and Brakes
Everything to do with wheels, tires,
suspension, forks and brakes

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 09-14-2007, 01:11 AM Thread Starter
 
Join Date: Apr 2007
Posts: 139
iTrader: (0)
 
Speedo not working

Yes I know this is for wheels, suspension and brakes but since it connects to the front tire and I didn'r see a better choice for posting, here I am. My speedo stopped working along with the trip meter but the regular odometer is still working. It lloks like the cable is connected okay to both the front tire and the gauge. Any suggestions?
Cardinal Fang is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 09-14-2007, 04:28 AM
and the Adventure Cycle
 
hyperbuzzin's Avatar
 
Join Date: Jun 2004
Location: Western PA
Posts: 6,138
iTrader: (1)
   
Dianna has suggested before to blow compressed air into the speedo.
Sometimes just a tiny piece of 'stuff' can get in between the gears and cause then to stop working.
It's cheap and easy to try, and it just might fix things


AKA: Tim & 'The Adventure Cycle' VROC #24567, NEVROC, SteelCity VROC


"When life throws you curves,
Aim for the apex."

Author Unknown
hyperbuzzin is offline  
post #3 of 4 (permalink) Old 09-14-2007, 04:53 AM
 
Join Date: Apr 2006
Posts: 17
iTrader: (0)
 
Mine stopped working in febuary but my odometer doesnt work either. I do hear a sqeaking noise when I turn hard left. So in my case I think its the lower gear....
jtabaco is offline  
 
post #4 of 4 (permalink) Old 09-14-2007, 08:47 AM
Senior Member
 
BMan23777's Avatar
 
Join Date: Mar 2007
Location: Near Cooperstown, New York
Posts: 722
iTrader: (0)
 
once and a while mine will stop and a tap on the side of it gets it working again.

Brian Manchester
'89 "GRIMM"

CUSTOM-Seat,quick detach backrest,2.5"slam brackets,Pipes,Fender struts,head light mount,9"rise dragbars,Grips,Mirrors, turnsignals,LED brake light/Lic.plate frame,Chopper headlight. Shaved,Jetted,coastered,polished forks,saddle&Tool bags,horns moved,180/70/15 rear tire!!! Yes a 180!!!!And other stuff.....
Springfield 1911-A1 Compact .45acp

03 F250 superduty 4x4 V-10 crew cab long box 33's,CAI,SS duals with magnaflow

04 durango AWD
BMan23777 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Once registered, your User Name"cannot be changed". We can make exceptions within 7 days, but after that, it is set in stone.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome