Speedo cable - Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums
Wheels, Suspension and Brakes
Everything to do with wheels, tires,
suspension, forks and brakes

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-26-2012, 11:25 PM Thread Starter
'03 VN750 "Rosie"
 
bstew7890's Avatar
 
Join Date: Jun 2010
Location: Albuquerque, NM
Posts: 227
iTrader: (0)
 
Speedo cable

A weird thing happened today. I took the Vulcan to work today and had to run an errand in the middle of the day. Heading out for the errand I suddenly noticed the speedometer wasnt registering. After 3-4 miles of freeway driving I got to my destination and went in. Coming back out I saw the speedo cable laying under the bike; it was still attached to the front axle and I guess I had dragged it down the freeway. I tried to put it back but apparently never quite got it threaded as it came off again in a few hundred yards. Luckily it fell on my foot peg and I was able to keep it from dragging on the ground. Before coming come I screwed it on again Nd this time it stayed on for the 5 mile ride home.

Has this happened to you? Is it time to replace the cable? It's banged up and scratched from its ride on the freeway.

'03 VN750 "Rosie"
Purchased in June 15, 2010
Windshield
Lubed Splines
Lubed and Adjusted Clutch Cable, Throttle Cables.
Relocated Voltage Regulator
Brakes Bled
Luggage Rack
Lazy Rider Bag
Leather Saddle Bags
Legitimate Title!! (finally!) Aug 30, 2010
New AGM Interstate Battery Sept 15, 2012

2008 Hyosung GV250 (sold!)
bstew7890 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-26-2012, 11:47 PM
Old Truck Junkie
 
niterider's Avatar
 
Join Date: Jul 2007
Location: Roby Texas
Posts: 4,130
iTrader: (15)
 
If the speedo still works. I would just tighten it with some pliers. You might want to relube it.

02 honda sabre 1100
niterider is offline  
post #3 of 4 (permalink) Old 03-27-2012, 04:01 PM
..have a vulcan good day!
 
WilliamTech's Avatar
 
Join Date: May 2011
Location: Pensacola, FL.
Posts: 4,508
iTrader: (17)
   
Yeah, I experienced the same more than once. I finally put some Lock-Tite on the threads.... no problem since.
Good Luck
WilliamTech

'86 VN750 13,700 mi -Stock
-Purchased 2008 w/8800mi
Replaced ALL Cables . Kuryakyn LED Voltmeter
SilverStar Ultra 9003/HB2 H4 Headlamp, Jardine Fwd Controls,
Iridiums DPR7EIX-9 & Wires, Tuxedo Mod, Coil Mod, P/U Sensor Mod, Fork Seals,
Splines Lubed - 11/4/2012 - MF AGM Battery
Additional Flashing LED Brake Light on Trunk
Dampers went out @ 13+K !
After TOC MCCT's..... so amazingly quiet I discovered a rattling heat shield on my stock exhaust !
...have a vulcan good day!
WilliamTech is offline  
 
post #4 of 4 (permalink) Old 03-27-2012, 04:37 PM
gun slinger
 
centurynick's Avatar
 
Join Date: Jul 2010
Location: outside toledo ohio
Posts: 1,110
iTrader: (0)
 
Garage
mine always loosens it self from the speedo head i retighten it and a few weeks later its loose again. i never had it fall off the bike it just loosens it self up .. im going to lock tight it on next ( i have been saying that for the last few years tho

2010' voyager

2005 1600 nomad sold

1987 kawasaki vulcan 750 SOLD

1985 kawasaki vulcan 700 parts bike maybe
lots of hand guns
3 cagers doors kicked in

Last edited by centurynick; 03-27-2012 at 04:40 PM.
centurynick is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Once registered, your User Name"cannot be changed". We can make exceptions within 7 days, but after that, it is set in stone.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome