Spongy front break - Page 2 - Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums
Wheels, Suspension and Brakes
Everything to do with wheels, tires,
suspension, forks and brakes

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 11 (permalink) Old 07-04-2009, 06:10 PM
Senior Member
 
1986vn750's Avatar
 
Join Date: Jun 2009
Location: Va
Posts: 399
iTrader: (0)
 
I totally dissassembled my breaks. lines of, everything. The fluid was brown and was contaminated with water. I did get the screws out with the impact wrench, works great! i took the piston out of the resevoir, and you would not believe how much junk was in there. Tomorrow i will flush everything out, bench bleed it, then hook it all back up.

1986 Vn750
18,800 miles, and counting
Bone Stock
New cam chain tentioners
all fluids changed
Spline Lube
windshield
Engine Guard
B-stone S11 RWL-stock sizes
*wanted*
New grips

2001 Vn750
13,100 miles, and counting
spline lube
Bridgestone S11 100/90
Shinko 170/80
rear end oil change
aftermarket mirrors
windshield
otherwise all stock
*anticipated mods*
Engine Guard
1986vn750 is offline  
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Reply

Bookmarks

Tags
front break , water in lines

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Once registered, your User Name"cannot be changed". We can make exceptions within 7 days, but after that, it is set in stone.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome