Turn Signals not Blinking - Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums
Electrical
Where does this wire go?
Includes Electrical mods, Lights, Stator,
Rectifier, Diagrams, etc

 1Likes
  • 1 Post By Spockster
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-07-2016, 12:30 PM Thread Starter
Senior Member
 
Join Date: Jul 2012
Location: South Jersey
Posts: 456
iTrader: (6)
 
Turn Signals not Blinking

Wow its been a long time since I've been here....
Anyway can someone verify my thinking on this before I tear into it
when i get back home from traveling.

My turn signals will not blink, they were working fine, no changes made. They light up no problem, the front gets brighter like they should and the rear come on and stay on until turn the switch off.

The turn signal relay is bad right?

The reason why im even questioning this is I replaced the relay with the Ep-34 about a year ago when i changed out for the LED's.
Has anyone else had one of these go bad in such a short time frame? (and no I didn't go buy the 4 dollar eBay special from china either)


Thanks
jj23 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-07-2016, 12:43 PM
Senior Member
 
Spockster's Avatar
 
Join Date: Nov 2012
Location: WV
Posts: 6,669
iTrader: (5)
   
I'd say bad flasher or flasher got wet.

Mine behaved the same way when I got it wet. Got caught in some rain, came home and washed the bike, then the signals would light, but wouldn't flash.

Found the EP34 hanging upside down, opened it up, dried it out, then sealed it and hung it with the plug facing down. Worked fine ever since, the flasher was on the bike when I bought it in 2013.
Thorn likes this.

2003-21k mi
Shaved w/UniPK92+Stock Jets-TPE/MOSFET-Shinko Tires-AGM batt-bags-chrome-LEDs...more
__________________________________________________ ____________
Repair Manual: http://www.mediafire.com/file/mj7z81..._Catalogue.pdf

Owner's Manual: http://www.mediafire.com/file/nscb5f...ers+Manual.pdf
Spockster is offline  
post #3 of 4 (permalink) Old 07-07-2016, 12:48 PM
Super Moderator
 
Join Date: Feb 2013
Location: SW Florida
Posts: 2,463
iTrader: (5)
 
sounds like a dead ep34.

I have had mine on the bike for close to 2 yrs now, no problems..

2005 VN750

Sold 11-27-17
michiganteddybear is offline  
 
post #4 of 4 (permalink) Old 07-07-2016, 01:00 PM Thread Starter
Senior Member
 
Join Date: Jul 2012
Location: South Jersey
Posts: 456
iTrader: (6)
 
That's what I thought, maybe I just got a bad flasher.....

Thanks for verifying guys.
jj23 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Once registered, your User Name"cannot be changed". We can make exceptions within 7 days, but after that, it is set in stone.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome