Gauge Backlight Issues - Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums
Electrical
Where does this wire go?
Includes Electrical mods, Lights, Stator,
Rectifier, Diagrams, etc

 1Likes
  • 1 Post By michiganteddybear
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-31-2016, 08:01 AM Thread Starter
Senior Member
 
dgulley21's Avatar
 
Join Date: Apr 2015
Location: Cincinnat OH
Posts: 112
iTrader: (1)
 
Gauge Backlight Issues

So after recently completing my rebuild on my engine and setting everything up I seem to have lost all back light on gauges and dash light when you turn the key to start the bike. any ideas?
dgulley21 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-31-2016, 08:37 AM
Super Moderator
 
Join Date: Feb 2013
Location: SW Florida
Posts: 2,434
iTrader: (5)
 
1st off, make sure all the connections you not only had to deal with to remove then engine, but the ones you didnt mess with... then look at the JB (fuses).. and then the ign switch.

pay particular attention to the connections/wiring under the neck covers
WilliamTech likes this.

2005 VN750

Sold 11-27-17
michiganteddybear is offline  
post #3 of 4 (permalink) Old 05-31-2016, 12:07 PM
..have a vulcan good day!
 
WilliamTech's Avatar
 
Join Date: May 2011
Location: Pensacola, FL.
Posts: 4,508
iTrader: (17)
   
Quote:
Originally Posted by michiganteddybear View Post
1st off, make sure all the connections you not only had to deal with to remove then engine, but the ones you didnt mess with... then look at the JB (fuses).. and then the ign switch.

pay particular attention to the connections/wiring under the neck covers
x2 - -

'86 VN750 13,700 mi -Stock
-Purchased 2008 w/8800mi
Replaced ALL Cables . Kuryakyn LED Voltmeter
SilverStar Ultra 9003/HB2 H4 Headlamp, Jardine Fwd Controls,
Iridiums DPR7EIX-9 & Wires, Tuxedo Mod, Coil Mod, P/U Sensor Mod, Fork Seals,
Splines Lubed - 11/4/2012 - MF AGM Battery
Additional Flashing LED Brake Light on Trunk
Dampers went out @ 13+K !
After TOC MCCT's..... so amazingly quiet I discovered a rattling heat shield on my stock exhaust !
...have a vulcan good day!
WilliamTech is offline  
 
post #4 of 4 (permalink) Old 05-31-2016, 09:55 PM Thread Starter
Senior Member
 
dgulley21's Avatar
 
Join Date: Apr 2015
Location: Cincinnat OH
Posts: 112
iTrader: (1)
 
Well I definitely panicked on this one just a blown fuse while hooking up my gauge cluster.
dgulley21 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Once registered, your User Name"cannot be changed". We can make exceptions within 7 days, but after that, it is set in stone.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome