Right turn signals dont work - Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums
Electrical
Where does this wire go?
Includes Electrical mods, Lights, Stator,
Rectifier, Diagrams, etc

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-30-2011, 06:02 PM Thread Starter
Senior Member
 
Diamondjim05's Avatar
 
Join Date: Dec 2010
Location: Denton, Tx
Posts: 115
iTrader: (0)
 
Right turn signals dont work

I just bought a new to me left hand switch set. I installed it the other day and tested the turn signals, they worked then. I tried them again today, and the left side worls but the right side doesnt. It doesnt light up, it doesnt blink, the relay doesnt even click. I have no idea where to start looking. Any ideas? Im not to sure if if matters or not but my bike is an 86 and the switch came off of a 90. the plugs were the same, needed no modification to make it fit.

Devin Mohler
Corporal, United States Marine Corps

1989 Honda Interceptor 500
1986 Vulcan 750, paid in full (250 bucks)

R/R Relocated (Thanks flitecontrol)
Splines Lubed
Battery Tender permanetly installed
Custom Seat

Planned mods and things:
Ear shave (using stock ears as storage)
Coastering
Wrapping exhaust
Custom Exhaust
Diamondjim05 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-30-2011, 08:16 PM
Old Truck Junkie
 
niterider's Avatar
 
Join Date: Jul 2007
Location: Roby Texas
Posts: 4,130
iTrader: (15)
 
Start with checking the bulb.

02 honda sabre 1100
niterider is offline  
post #3 of 5 (permalink) Old 01-30-2011, 08:22 PM Thread Starter
Senior Member
 
Diamondjim05's Avatar
 
Join Date: Dec 2010
Location: Denton, Tx
Posts: 115
iTrader: (0)
 
That was the first thing i checked, I guess i should have mentioned that. I also checked for power at the socket. No power at the rear signal, but good ground, i tested it. Also no power at the plugs in the harness for the right rear turn signal. Checked the front. Have power for the running lights, but no turn signal power. I am at a loss.....

Devin Mohler
Corporal, United States Marine Corps

1989 Honda Interceptor 500
1986 Vulcan 750, paid in full (250 bucks)

R/R Relocated (Thanks flitecontrol)
Splines Lubed
Battery Tender permanetly installed
Custom Seat

Planned mods and things:
Ear shave (using stock ears as storage)
Coastering
Wrapping exhaust
Custom Exhaust
Diamondjim05 is offline  
 
post #4 of 5 (permalink) Old 01-30-2011, 09:12 PM
Old Truck Junkie
 
niterider's Avatar
 
Join Date: Jul 2007
Location: Roby Texas
Posts: 4,130
iTrader: (15)
 
The problem is very likely at the switch.

02 honda sabre 1100
niterider is offline  
post #5 of 5 (permalink) Old 01-31-2011, 05:29 AM
Banned
 
Join Date: Dec 2010
Posts: 448
iTrader: (3)
 
X2 on the bad switch.
RakerBill is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Vulcan 750 Forum : Kawasaki VN750 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Once registered, your User Name"cannot be changed". We can make exceptions within 7 days, but after that, it is set in stone.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome